Get in touch
Back
Maintenance

Panel Update, PHPMyAdmin panel addition

Completed 25 Oct at 08:00pm PKT.

Pterodactyl Panel
Completed

Maintenance completed

Posted 25 Oct at 08:00pm PKT.
Started

We are currently adding a new update to the panel, for you to directly access PMA or PHPMyAdmin just with a single click.

Posted 25 Oct at 07:45pm PKT.