Get in touch
Back
Maintenance

Possible Power Supply Change (FAILED)

Completed 31 Oct at 03:36am PKT.

Pterodactyl Panel PHPMyAdmin
Completed

Maintenance completed

Posted 31 Oct at 03:36am PKT.
Started

Currently going to replace PSU on the machine, to ensure stability.

Posted 31 Oct at 03:26am PKT.