Get in touch
Back
Maintenance

Changing to Cloudflare Proxy

Completed 12 Nov at 09:28pm PKT.

Pterodactyl Panel
Completed

Maintenance completed

Posted 12 Nov at 09:28pm PKT.
Started

We are currently changing to cloudflare proxy for the time being

Posted 12 Nov at 03:28pm PKT.